Below is the text of the page https://www.hostmaster.ua/idn stored 2020-12-11 by archive.org.ua. The original page over time could change. View as original html

Hostmaster Ltd. | IDN domains

[] .UA - наш дiм. Зробимо його кращим! Ваша IP адреса: 77.120.117.18 English Українська Русский Головна Домени Документи Реєстратори Допомога Новини Статистика IDN DNSSEC Контакти Вхiд Шукати домен Розширений пошук Пошук доменів реєстранта (.gov.ua, .edu.ua) Інформація щодо nic-handle -UANIC Операції з nic-handle Інформація щодо epp-contact Транслітерація Таблиці транслітерації Публічні домени Міжнародне співробітництво IDN домени 1. Що таке IDN? 2. Як працює IDN? 3. Як буде виглядати IDN домен у сервісі WHOIS? 4. Як відображується IDN домен у системі DNS? 5. Які символи можна використовувати для реєстрації IDN-доменів? 6. Чи можна зареєструвати IDN домен з апострофом? 7. Як ввести український апостроф з клавіатури? 8. Чи є якісь особливості при продовженні чи зміні IDN-доменів? Словник термінів 1. Що таке IDN? IDN (скорочено від Internationalized Domain Names) - це доменні імена, що містять символи національних алфавітів, наприклад: незалежність.com.ua Домен IDN має дві форми відображення: ім'я записується "звичайними" символами (Unicode), наприклад, їжачок.pl.ua) ім'я записується ASCII-символами для внутрішнього представлення імені в системі DNS (xn--80alnp8bxf.pl.ua) Ця форма також має назву ACE (ASCII Compatible Encoding) Стандарт представлення символів знаходиться в документах: RFC 3490 Internationalizing Domain Names in Applications (IDNA) RFC 3491 Nameprep: A Stringprep Profile for Internationalized Domain Names (IDN) RFC 3492 Punycode: A Bootstring Encoding of Unicode for Internationalized Domain Names in Applications (IDNA) Детальну інформацію про використання IDN доменів можна отримати на сайті http://idn.icann.org 2. Як працює IDN? Ім'я, яке користувач вводить в адресному рядку, автоматично перетворюється браузером в символи, що відповідають кодуванню ASCII та є допустимі для використання у звичайній системі DNS. До перетворенного доменного імені додається спеціальний префікс "xn--", який показує, що воно складено з символів національних алфавітів. 3. Як буде виглядати IDN домен у сервісі WHOIS? При виводі WHOIS IDN домени відображаються у формі ACE. Приклад: % % .UA whois % Domain Record: % ============= domain: xn--80alnp8bxf.pl.ua admin-c: ST101-UANIC tech-c: TLC-UANIC status: OK-UNTIL 20100422000000 .... 4. Як відображається IDN домен у системі DNS ? В DNS використовується тільки ACE-форма домену Приклад: xn--80alnp8bxf.pl.ua IN NS ns1.aaaa.bbb.com. IN NS xn--80alnp8bxf.pl.ua. xn--80alnp8bxf.pl.ua IN A 193.194.12.7 5. Які символи можна використовувати для реєстрації IDN-доменів? В реєстраційній системі UANIC до реєстрації приймаються доменні імена з префиксом "xn--", відповідне Unicode-представлення яких містить символи, що належать тільки до одного з наборів символів, визначених у документі "Регламент реєстрації IDN-доменів" (на теперішній час це набори символів ASCII та Кирилиця). Змішування знаків, що належать до різних наборів, не допускається. На формі Unicode-Punycode Конвертор можна перекодувати слова, записані кирилицею, у формат ACE (з префіксом "xn--") та навпаки. Там же можна перевірити можливість реєстрації такого домену. 6. Чи можна зареєструвати IDN домен з апострофом? З 1 червня 2012 року Ви маєте можливість зареєструвати IDN домени з українським апострофом. Для цього Вам необхідно звернутися до реєстраторів, які здійснюють реєстрацію IDN доменів. Список реєстраторів див. на сторінці https://hostmaster.ua/registrars 7. Як ввести український апостроф з клавіатури? В операційній системі Windows необхідно, утримуючи клавішу Alt, набрати на цифровій клавіатурі "700" (це код U +02 BC в звичному для нас десятковому вигляді). В операційній системі Linux необхідно натиснути Ctrl-Shift-U. З'явиться маленька підкреслена буква u. Після цього потрібно ввести шістнадцятковий код 2BC і натиснути Enter. В операційній системі MacOS в Libre Office необхідно вибрати в меню Insert -- Special Characters, Subset = Cyrillic і вибрати символ з кодом U+2BC. Після цього Ви можете скопіювати символ і використовувати його при написанні доменного імені. 6. Чи є якісь особливості при продовженні чи зміні IDN-доменів Продовження, зміна, переведення до іншого реєстратора, зміна реєстранта для доменів IDN здійснююься так само, як і для звичайних доменних імен. У заявці необхідно вказати доменне ім'я, що перетворено до виду "xn--". Словник термінів ASCII ASCII (скорочено від American Standard Code for Information Interchange) - американський стандартний код для обміну інформацією. Таблиця ASCII символів містить алфавітні символи та відповідні ним цифрові коди. Існує два види ASCII-коду: 7-бітовий (128 знаків) та 8-бітовий (256 знаків, в який входять також деякі букви европейських мов). Unicode Unicode (Юникод, Уникод) - 16-бітний стандарт кодування символів, що дозволяють представити знаки практично всіх письмових мов. Використання цього стандарту дозволяє закодувати больше число символів з різних писемностей: у документах Unicode можуть одночасно знаходитися китайські ієрогліфи, математичні символи, букви грецього алфавиту, кирилиці тощо. Більш детально про Юникод можна дізнатися на сайті www.unicode.org . Punycode Punycode - алгоритм, який визначає однозначне перетворення символів Юникоду в рядки ASCII-символів. Технічне визначення цього алгоритму знаходиться в RFC3492 Punycode: A Bootstring Encoding of Unicode for Internationalized Domain Names in Applications. ACE (ASCII Compatible Encoding) - форма представлення символів національних алфавітів у доменних іменах. Префікс "xn--" також називають ACE-префіксом. Події Архів заходів Робочі групи Майстерня нових технологій Новини 10.12.2020 Дайджест доменних подій 03.12.2020 Дайджест доменних подій 02.12.2020 Домен .UA відзначає 28 років 26.11.2020 Дайджест доменних подій 19.11.2020 Конференцію UADOM перенесено на 2021 рік Всі новини >> 2020 Архів дайджестів доменних подій Про компанію Пам'ятаємо 0,352519 sec © Hostmaster (TM) Ltd., 2001-2020 передрук матеріалів за умови посилання на hostmaster.ua