Below is the text of the page https://www.ukrcc.com/company.html stored 2006-11-06 by archive.org.ua. The original page over time could change. View as original html

[#] Міжнародні стандарти ISO/IEC, IETF, ETSI визначають та стандартизують широке коло рішень у сфері застосування технологій інфраструктури з відкритим ключем PKI (Public key infrastructure). Для забезпечення взаємодії програмних продуктів зазначені стандарти передбачають велику гнучкість щодо форм реалізації (протоколів, форматів даних, технологічних процедур тощо). З метою забезпечення взаємодії програмно-технічних рішень між компонентами ЦСК УСЦ розроблені технічні специфікації, які: - визначають низку стандартів, яких дотримувалися при розробці програмного забезпечення ЦСК УСЦ та його користувачів; - обмежують можливі альтернативні реалізації, передбачені міжнародними стандартами; - встановлюють технічні вимоги до об’єктів, що не охоплені міжнародними стандартами, але потрібні для забезпечення взаємодії. Автоматизована система ЦСК УСЦ складається з підсистеми відкритого доступу і підсистеми обслуговування абонентів. Вона призначена: - створювати структури бази даних та керувати масивами даних; - обчислювати параметри для криптографічних перетворень; - створювати пари ключів (особистий і відкритий) та обчислювати сертифікати відкритих ключів ЦСК УСЦ (кореневі, корпоративні та особові); - за заявками клієнтів обчислювати сертифікати відкритих ключів, сумісні з Х.509 версії 3 (сертифікати містять відкриті ключі клієнтів); - керувати сертифікатами відкритих ключів (введення до бази даних, витяг з бази даних, перевірка відповідності, експорт/імпорт у бінарному форматі та форматі base 64, блокування, скасування); - створювати списки скасованих сертифікатів відкритих ключів у форматі Х.509 версії 2; - керувати списками скасованих сертифікатів відкритих ключів (внесення скасованого сертифікату до списку, створення часткових списків скасованих сертифікатів, експорт/імпорт списку у бінарному форматі, перевірка списку); - скасувати сертифікат відкритого ключа за запитом абонента, або з власної ініціативи (відповідно до вимог регламенту ЦСК УСЦ); - керувати доступом до бази даних сертифікатів відкритих ключів та реєстру заявок; - керувати доступом до особистих ключів асиметричних криптографічних перетворень; - керувати повноваженнями операторів ЦСК УСЦ; - вести протоколи роботи ЦСК УСЦ; - забезпечувати синхронізацію з Всесвітнім координованим часом ( UTC ) з точністю до однієї секунди; - формувати за запитом клієнта криптографічну позначку часу (за Київським часом); - формувати за запитом клієнта повідомлення про поточний стан сертифікатів відкритих ключів; - транспортувати сертифікати відкритих ключів, заявки на сертифікати відкритих ключів, списки скасованих сертифікатів відкритих ключів, заявки на скасування сертифікатів відкритих ключів, позначки часу засобами Web та електронної пошти; - забезпечувати захищений обмін даними з клієнтами УСЦ. Перелік документів, на підставі яких створена автоматизована система ЦСК УСЦ - Закон України “Про інформацію” від 2 жовтня 1992 р. № 2657-XII; - Закон України “Про електронні документи та електронний документообіг” від 22 травня 2003 р. № 851-IV; - Закон України “Про електронний цифровий підпис” від 22 травня 2003 р. № 852-IV; - “Порядок акредитації центру сертифікації ключів”, затверджений постановою Кабінету Міністрів України від 13 липня 2004 р. № 903; - “Правила посиленої сертифікації”, затверджені наказом Департаменту спеціальних телекомунікаційних систем та захисту інформації Служби безпеки України від 13.01.2005 № 3; - Наказ Департаменту спеціальних телекомунікаційних систем та захисту інформації Служби безпеки України від 10.05.2006 № 50 “Про внесення змін до Правил посиленої сертифікації”; - ГОСТ 28147-89 “ Системы обработки информации. Защита криптографическая. Алгоритм криптографического преобразования ” ; - ГОСТ 34. 311-95 “ Информационная технология. Криптографическая функция хеширования ” ; - ДСТУ 4145-2002 “Інформаційні технології. Криптографічний захист інформації. Цифровий підпис, що ґрунтується на еліптичних кривих. Формування та перевіряння”; - IETF RFC 3280: "Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile"; - ITU-T Recommendation X.509/ISO/IEC 9594-8: "Information technology – Open Systems Interconnection - The Directory: Public-key and attribute certificate frameworks"; - IETF RFC 3739: "Internet X.509 Public Key Infrastructure: Qualified Certificates Profile"; - IETF RFC 3279: "Algorithms and Identifiers for the Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile"; - X. 509 ITU- T Recommendations X. 509. The Directory – Public Key and Attribute Certificates Framework . 2000; - X. 680 ITU- T Recommendations X. 680. Information Technology – Abstract Syntax Notation One (ASN.1). Specification of Basic Notation . 1994; - X. 690 ITU- T Recommendations X. 690. Information Technology – (ASN.1). Encoding Rules . 1994; - PKCS#7 Cryptographic Message Syntax . 1993; - PKCS#8 Private-Key Information Syntax Standard . 1993; - PKCS#10 Certification Request Syntax Standard . 2000; - PKCS#12 Personal Information Exchange Syntax . 1999; - ISO/IEC 9646: Information Technology – Open Systems Interconnection – Conformance Testing Methodology and Framework . 1994; - T7 i.Gr., TeleTrusT: ISIS-MTT Specification, Common ISIS-MTT Specification for PKI Applications; Version 1.0.1 . November 2001. Схема організаційної структури УСЦ На схемі, для кожної особи як структурної одиниці, вказані кваліфікаційна категорія і посади ЦСК, функції яких особа забезпечує. Першою зазначена основна посада, а другою - посада, функції якої особа виконує у разі відсутності основної посадової особи. Кількість операторів сертифікаціі і операторів реєстрації залежить від навантаження ЦСК.